Is Flash required to play AQWorlds?

You need to have Flash installed to play AQWorlds. You can get Flash Player from Adobe's Official site, here.

Please always make sure that you are using the most recent upgrade of Flash when playing AQWorlds, which is Flash Version 9.0 and up. If you do not, it could cause problems with your browser and playing our game.

If for some reason Flash is not working for you even after updating to a new version and you are experiencing lag, you can try an older version to see if that helps. Usually only the newest version will work the best.

Get AdventureCoins! Earn AdventureCoins
Character Lookup
HeroMart
Our Mobile Apps
BattleGems BattleGems
Dragons Dragons
Our Web Games
DragonFable MechQuest EpicDuel OverSoul AdventureQuest All Artix Games